[FreeBSD 10]_解決 “This port is marked DEPRECATED” 的問題

今天在FBSD安裝APACHE 2.4 的時候,出現了以下的問題,其中我列出比較重點的部分:

 

===>>> This port is marked DEPRECATED

===>>> Unsupported, please upgrade to a more recent version of Perl

 

看起來是現有安裝的Perl版本太舊了

但..port tree都更新了,重新安裝還是一樣…

 

找了一下google,知道把perl重新刪掉安裝就可以解決,所以來是看看看吧:

pkg delete perl5.xx.xx.xx

 

 

代表移除perl5.xx.xx.xx的套件,xx請換成自己電腦上的版本,當然可以如法炮製,如果Deprecated的套件不是Perl,請自己依樣畫葫蘆

 

刪除完畢之後重新安裝Apache就可以解決這個小問題順利安裝Apache!

 

 

最後簡單Note一下用portmaster安裝Apache的方法:

portmaster -G www/apache24

 

 

以上~

 

thx for:

https://forums.freebsd.org/threads/cant-upgrade-ports-after-update-to-freebsd-10-0-release.44735/

Leave a comment

Your email address will not be published.




這個網站採用 Akismet 服務減少垃圾留言。進一步瞭解 Akismet 如何處理網站訪客的留言資料

Bitnami