[Android]_解決在Ubuntu 14.04 x64上建置Android 4.4 ROM For Nexus 5 找不到 libz.so.1

今天make android ROM 時,在make rule執行檢查的過程中出現:

prebuilts/gcc/linux-x86/host/i686-linux-glibc2.7-4.6/bin/../lib/gcc/i686-linux/4.6.x-google/../../../../i686-linux/bin/as: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory

make: *** [out/host/linux-x86/obj/EXECUTABLES/mkbootimg_intermediates/mkbootimg.o] Error 1

 

簡單來說就是缺少libz.so.1這個library,

但有時候會不知道這個library是包含在哪個library package裡面

 

這時可以透過apt-file這個程式來幫助你找到你所需要安裝的library package

 

1.更新apt來源並且安裝apt-file

sudo apt-get update
sudo apt-get install apt-file

 

2.更新apt-file自己的查詢套件list

apt-list update

 

3.查詢libz.so.1包含在哪個package

apt-file search libz.so.1

 

會顯示:

nathaniel@NTL-VMGuest-U1404D:~$ apt-file search libz.so.1
lib32z1: /usr/lib32/libz.so.1
lib32z1: /usr/lib32/libz.so.1.2.8
libx32z1: /usr/libx32/libz.so.1
libx32z1: /usr/libx32/libz.so.1.2.8
zlib1g: /lib/x86_64-linux-gnu/libz.so.1
zlib1g: /lib/x86_64-linux-gnu/libz.so.1.2.8
nathaniel@NTL-VMGuest-U1404D:~$

 

這時會發現後面會找出匹配的library, 這裡就是安裝lib32z1

 

4.安裝lib32z1

sudo apt-get install lib32z1

 

之後重新編譯看看,應該就會很順利地繼續下去了~

 

thx for:

http://blog.csdn.net/shatelang/article/details/43328555

 

Leave a comment

Your email address will not be published.




這個網站採用 Akismet 服務減少垃圾留言。進一步瞭解 Akismet 如何處理網站訪客的留言資料

Bitnami